Date: Wed, 1 Feb 2006 18:20:33 -0800
authorSam Lantinga <slouken@libsdl.org>
Thu, 02 Feb 2006 06:26:39 +0000
changeset 1321e05bc5d315e3
parent 1320 2a2f31cc4c8b
child 1322 a4566d07718f
Date: Wed, 1 Feb 2006 18:20:33 -0800
From: Eric Wing
Subject: SDL/Universal Binary updates

Hi Sam,
Attached is a big set of changes to the Xcode projects to support
Universal Binaries. I have also included .dmgs that include the
prebuilt frameworks.

Ryan, I also updated SMPEG which is also in the package.

The SDL and smpeg binaries were built against the CVS version (pulled
maybe a month ago?).

I do not have an Intel Mac to test on so I have no idea if this stuff
actually works. However, Christian Walther has been a big help in
testing 10.2.8 and 10.3.9 so I'm fairly confident we got the build
settings correct for at least PPC.

I have attempted to document the important things for producing these
Universal Binaries. Documentation is somewhat scattered through out
everything, but there is a big centralized piece of documentation in
the UniversalBinaryNotes.rtf in the SDL.dmg.

As far as Universal Binaries are concerned, the big things were:
- Build with gcc 3.3 on PPC, 4.0 on Intel.
- We couldn't get any of the MMX/SSE code to compile/link (SDL and
smpeg).
- All 3rd party dependencies had to be rebuilt as Universal

There were also a bunch of non-Universal things that have been updated:
- I converted the SDL-satellites to create .dmg's instead of .pkg
installers
- Updated all 3rd party static libraries with current versions. (I
think libpng was the most dramatic going from 1.0.? to 1.2.8 with API
breakage. I haven't found any problems so far in doing this.)
- Changed some compiler optimization settings
- Finally updated the exports list for SDL_mixer
- Tried to include a static smpeg in SDL_mixer (multiple build
variants in Xcode project now)
- Enabled Altivec in SDL (we forgot to add the flags to Xcode last time)
- More documentation

Since so many things have changed, there might be new problems
introduced. The big issue I've found so far is with SDL_mixer. As I
mentioned on the mailing list, MP3's produce an assertion failure.
And the MikMod problem reported on Bugzilla continues to persist.

There's probably a bunch of other stuff I'm forgetting. There really
were hundreds of little things I mucked with so it's hard to remember
them all.

If you have any questions, feel free to ask.

Thanks,
Eric
Makefile.am
     1.1 --- a/Makefile.am	Thu Feb 02 05:35:42 2006 +0000
     1.2 +++ b/Makefile.am	Thu Feb 02 06:26:39 2006 +0000
     1.3 @@ -48,6 +48,7 @@
     1.4  	EpocBuildFiles.zip \
     1.5  	Xcode.tar.gz	\
     1.6  	Xcode21.tar.gz	\
     1.7 +	XcodeUniversal.tar.gz	\
     1.8  	WhatsNew	\
     1.9  	docs.html	\
    1.10  	sdl.m4		\