Updated required Android SDK to API 26, to match Google's new App Store requirements
authorSam Lantinga <slouken@libsdl.org>
Tue, 21 Aug 2018 20:46:25 -0700
changeset 121416b61de046a2f
parent 12140 e1f20a3214d9
child 12142 b2123abf97e0
Updated required Android SDK to API 26, to match Google's new App Store requirements
android-project/app/build.gradle
docs/README-android.md
     1.1 --- a/android-project/app/build.gradle	Tue Aug 21 20:38:22 2018 -0700
     1.2 +++ b/android-project/app/build.gradle	Tue Aug 21 20:46:25 2018 -0700
     1.3 @@ -8,14 +8,14 @@
     1.4  }
     1.5  
     1.6  android {
     1.7 -    compileSdkVersion 19
     1.8 +    compileSdkVersion 26
     1.9      buildToolsVersion "26.0.1"
    1.10      defaultConfig {
    1.11          if (buildAsApplication) {
    1.12              applicationId "org.libsdl.app"
    1.13          }
    1.14          minSdkVersion 14
    1.15 -        targetSdkVersion 19
    1.16 +        targetSdkVersion 26
    1.17          versionCode 1
    1.18          versionName "1.0"
    1.19          externalNativeBuild {
     2.1 --- a/docs/README-android.md	Tue Aug 21 20:38:22 2018 -0700
     2.2 +++ b/docs/README-android.md	Tue Aug 21 20:46:25 2018 -0700
     2.3 @@ -14,10 +14,10 @@
     2.4   Requirements
     2.5  ================================================================================
     2.6  
     2.7 -Android SDK (version 19 or later)
     2.8 +Android SDK (version 26 or later)
     2.9  https://developer.android.com/sdk/index.html
    2.10  
    2.11 -Android NDK r10e or later
    2.12 +Android NDK r15c or later
    2.13  https://developer.android.com/tools/sdk/ndk/index.html
    2.14  
    2.15  Minimum API level supported by SDL: 14 (Android 4.0.1)