Wed, 09 Jul 2014 00:09:57 -0400The Gimp puts out a different bogus color mask for 32-bit .bmp files. :)
Ryan C. Gordon <icculus@icculus.org> [Wed, 09 Jul 2014 00:09:57 -0400] rev 9001
The Gimp puts out a different bogus color mask for 32-bit .bmp files. :)

Wed, 09 Jul 2014 00:01:34 -0400Make SDL_LoadBMP() work with 32-bit bitmaps from ImageMagick.
Ryan C. Gordon <icculus@icculus.org> [Wed, 09 Jul 2014 00:01:34 -0400] rev 9000
Make SDL_LoadBMP() work with 32-bit bitmaps from ImageMagick.

Tue, 08 Jul 2014 16:17:06 -0400Comment update: SDL_INIT_NOPARACHUTE doesn't do anything as of 2.0.0.
Ryan C. Gordon <icculus@icculus.org> [Tue, 08 Jul 2014 16:17:06 -0400] rev 8999
Comment update: SDL_INIT_NOPARACHUTE doesn't do anything as of 2.0.0.

Tue, 08 Jul 2014 00:42:14 -0700Skip JUNK chunks in wave files
Sam Lantinga <slouken@libsdl.org> [Tue, 08 Jul 2014 00:42:14 -0700] rev 8998
Skip JUNK chunks in wave files

Tue, 08 Jul 2014 00:23:36 -0700Strip the binaries before signing them, in release configuration
Sam Lantinga <slouken@libsdl.org> [Tue, 08 Jul 2014 00:23:36 -0700] rev 8997
Strip the binaries before signing them, in release configuration

Mon, 07 Jul 2014 23:48:21 -0700Fixed supporting multiple frameworks
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Jul 2014 23:48:21 -0700] rev 8996
Fixed supporting multiple frameworks

Mon, 07 Jul 2014 23:40:10 -0700Fixed code signing release frameworks
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Jul 2014 23:40:10 -0700] rev 8995
Fixed code signing release frameworks

Mon, 07 Jul 2014 23:33:57 -0700Update audio testautomation: more coverage; added SDL_PauseAudio test /w callback coverage
Andreas Schiffler <aschiffler@ferzkopp.net> [Mon, 07 Jul 2014 23:33:57 -0700] rev 8994
Update audio testautomation: more coverage; added SDL_PauseAudio test /w callback coverage

Mon, 07 Jul 2014 23:26:34 -0700Fixed bug 2421 - SDL_RenderCopyEx off by one when rotating by 90 and -90
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Jul 2014 23:26:34 -0700] rev 8993
Fixed bug 2421 - SDL_RenderCopyEx off by one when rotating by 90 and -90

chasesan

When using SDL_RenderCopyEx, I get a problem on some platforms where the output is offset by +/-1 on other platforms and not on others. I tried it with a center of both 0,0 (and offsetting by width/height) and NULL (for centered).

The rotation involved is 90, and/or -90 rotation. The rotation was a constant, no arithmetic was involved when inputting it into SDL_RenderCopyEx.

This occurred with 32x32, 24x24, and 16x16 texture sizes. I apologize that I don't have more precise information, as I received the information as a bug report myself. But I have tracked the problem down to here.

My program requires pixel perfect alignment on several different platforms, so this is something of a showstopper for me.

--

Sylvain

It appears the RenderCopyEx is done as expected,
this is the red rectangle which is not correctly positionned !

So, here's patch with a 0.5 float increment, like for opengles2, for DrawLines, and also Draw Points.

Mon, 07 Jul 2014 21:34:04 -0700Updated configure after removing pthread spinlock support
Sam Lantinga <slouken@libsdl.org> [Mon, 07 Jul 2014 21:34:04 -0700] rev 8992
Updated configure after removing pthread spinlock support