Thu, 01 Aug 2002 23:08:41 +0000*** empty log message ***
Sam Lantinga <slouken@libsdl.org> [Thu, 01 Aug 2002 23:08:41 +0000] rev 432
*** empty log message ***

Thu, 01 Aug 2002 23:06:39 +0000Fixed SDL_DisplayFormatAlpha() on RGB surfaces with alpha
Sam Lantinga <slouken@libsdl.org> [Thu, 01 Aug 2002 23:06:39 +0000] rev 431
Fixed SDL_DisplayFormatAlpha() on RGB surfaces with alpha

Thu, 01 Aug 2002 05:16:38 +0000Make sure width and height passed to SDL_GetVideoMode() are sane.
Ryan C. Gordon <icculus@icculus.org> [Thu, 01 Aug 2002 05:16:38 +0000] rev 430
Make sure width and height passed to SDL_GetVideoMode() are sane.

Tue, 30 Jul 2002 07:25:43 +0000Memory leak fixes by Bill May.
Ryan C. Gordon <icculus@icculus.org> [Tue, 30 Jul 2002 07:25:43 +0000] rev 429
Memory leak fixes by Bill May.

Mon, 29 Jul 2002 23:20:16 +0000Date: Fri, 12 Jul 2002 11:25:32 GMT+1
Sam Lantinga <slouken@libsdl.org> [Mon, 29 Jul 2002 23:20:16 +0000] rev 428
Date: Fri, 12 Jul 2002 11:25:32 GMT+1
From: Patrice Mandin <pmandin@caramail.com>
Subject: [SDL][PATCH] Audio for Atari, and XFree86 compilation

I corrected a little bug in the Atari audio driver in SDL.
I also added the patch for xfree86 detection in configure.in

Mon, 29 Jul 2002 22:26:43 +0000Date: Mon, 29 Jul 2002 15:07:22 +1000
Sam Lantinga <slouken@libsdl.org> [Mon, 29 Jul 2002 22:26:43 +0000] rev 427
Date: Mon, 29 Jul 2002 15:07:22 +1000
From: screwtape@froup.com

The attached patch lets SDL_Init(SDL_INIT_JOYSTICK) succeed on Mac OS
X when there are no joysticks attached, in line with SDL's behaviour
on Linux.

Fri, 26 Jul 2002 17:13:17 +0000Fix for USB HID API. Fixes build on NetBSD and FreeBSD, but maybe causes
Ryan C. Gordon <icculus@icculus.org> [Fri, 26 Jul 2002 17:13:17 +0000] rev 426
Fix for USB HID API. Fixes build on NetBSD and FreeBSD, but maybe causes
trouble on OpenBSD?

Mon, 22 Jul 2002 09:49:52 +0000Fixed (?) semaphore support on HPUX 11.x ...
Ryan C. Gordon <icculus@icculus.org> [Mon, 22 Jul 2002 09:49:52 +0000] rev 425
Fixed (?) semaphore support on HPUX 11.x ...

Wed, 10 Jul 2002 17:10:46 +0000*** empty log message ***
Sam Lantinga <slouken@libsdl.org> [Wed, 10 Jul 2002 17:10:46 +0000] rev 424
*** empty log message ***

Wed, 10 Jul 2002 05:18:09 +0000More correct error reported when calling SDL_GL_LoadLibrary() without
Ryan C. Gordon <icculus@icculus.org> [Wed, 10 Jul 2002 05:18:09 +0000] rev 423
More correct error reported when calling SDL_GL_LoadLibrary() without
prior call to SDL_Init().