configure.in
changeset 477 22581630aab7
parent 471 26dafefeebb2
child 512 fd7d603845dd
equal deleted inserted replaced
476:a7129c0083f4 477:22581630aab7
   777         if test x$PKG_CONFIG = xno ; then
   777         if test x$PKG_CONFIG = xno ; then
   778             AC_MSG_WARN([*** pkg-config is required to build the DirectFB video driver.])
   778             AC_MSG_WARN([*** pkg-config is required to build the DirectFB video driver.])
   779         else
   779         else
   780             AC_MSG_CHECKING(for DirectFB support)
   780             AC_MSG_CHECKING(for DirectFB support)
   781 
   781 
   782             if ! $PKG_CONFIG --atleast-pkgconfig-version 0.5 ; then
   782             if ! $PKG_CONFIG --atleast-pkgconfig-version 0.7 ; then
   783                 AC_MSG_ERROR([*** pkg-config too old; version 0.5 or better required.])
   783                 AC_MSG_ERROR([*** pkg-config too old; version 0.7 or better required.])
   784             fi
   784             fi
   785 
   785 
   786             DIRECTFB_REQUIRED_VERSION=0.9.11
   786             DIRECTFB_REQUIRED_VERSION=0.9.14
   787 
   787 
   788             if $PKG_CONFIG --atleast-version $DIRECTFB_REQUIRED_VERSION directfb ; then
   788             if $PKG_CONFIG --atleast-version $DIRECTFB_REQUIRED_VERSION directfb ; then
   789                 DIRECTFB_CFLAGS=`$PKG_CONFIG --cflags directfb`
   789                 DIRECTFB_CFLAGS=`$PKG_CONFIG --cflags directfb`
   790                 DIRECTFB_LIBS=`$PKG_CONFIG --libs directfb`
   790                 DIRECTFB_LIBS=`$PKG_CONFIG --libs directfb`
   791                 video_directfb=yes
   791                 video_directfb=yes