autogen.sh
author Sam Lantinga
Sun, 05 Apr 2020 08:58:47 -0700
changeset 13689 c3055b205671
parent 10722 30e271a26a02
permissions -rwxr-xr-x
Fixed bug 5015 - SDL_RenderReadPixels on DirectX 11.1 backend seems to be broken

Konrad

It appears that I cannot use SDL_RenderReadPixels on a bound framebuffer (SDL_Texture set as render target) as it simply results in gibberish data. However, drawing that framebuffer into the default target (window surface) does render it correctly. Other backends (OpenGL, software, Direct3D) do work fine.

It looks to me like D3D11_RenderReadPixels just gets the general backbuffer and not the current render target and its backbuffer.

Here is the patch which actually fetches the current render target and its underlying ID3D11Resource which is ID3D11Texture2D.
slouken@0
     1
#!/bin/sh
slouken@0
     2
#
slouken@1376
     3
echo "Generating build information using autoconf"
slouken@0
     4
echo "This may take a while ..."
slouken@0
     5
hadess@10398
     6
srcdir=`dirname $0`
hadess@10398
     7
test -z "$srcdir" && srcdir=.
icculus@10722
     8
cd "$srcdir"
hadess@10398
     9
slouken@0
    10
# Regenerate configuration files
slouken@7232
    11
cat acinclude/* >aclocal.m4
slouken@1564
    12
found=false
slouken@1832
    13
for autoconf in autoconf autoconf259 autoconf-2.59
slouken@1564
    14
do if which $autoconf >/dev/null 2>&1; then $autoconf && found=true; break; fi
slouken@1563
    15
done
slouken@1564
    16
if test x$found = xfalse; then
slouken@1564
    17
    echo "Couldn't find autoconf, aborting"
slouken@1564
    18
    exit 1
slouken@1564
    19
fi
slouken@1380
    20
(cd test; sh autogen.sh)
slouken@0
    21
slouken@0
    22
# Run configure for this platform
slouken@0
    23
echo "Now you are ready to run ./configure"