autogen.sh
author Sam Lantinga <slouken@libsdl.org>
Sun, 14 Jul 2013 18:17:28 -0700
changeset 7523 9e9ab1dc3811
parent 7232 6f17d930be39
child 10398 165f98326b5c
permissions -rwxr-xr-x
Fixed bug 1919 - Window icon disappears as soon as a renderer is created

Sebastian

Setting a window icon works just fine until a renderer is added to the window.
After adding the renderer the icon disappears.

Reproduce by:
- Take the example code from the wiki: http://wiki.libsdl.org/moin.fcg/SDL_SetWindowIcon

- Add the following two lines after SDL_FreeSurface(surface);
SDL_Delay(1000);
SDL_Renderer* ren = SDL_CreateRenderer(window, -1, SDL_RENDERER_ACCELERATED);

-compile and run

You will see the window icon correctly at first. After the Delay the Icon will disappear.
slouken@0
     1
#!/bin/sh
slouken@0
     2
#
slouken@1376
     3
echo "Generating build information using autoconf"
slouken@0
     4
echo "This may take a while ..."
slouken@0
     5
slouken@0
     6
# Regenerate configuration files
slouken@7232
     7
cat acinclude/* >aclocal.m4
slouken@1564
     8
found=false
slouken@1832
     9
for autoconf in autoconf autoconf259 autoconf-2.59
slouken@1564
    10
do if which $autoconf >/dev/null 2>&1; then $autoconf && found=true; break; fi
slouken@1563
    11
done
slouken@1564
    12
if test x$found = xfalse; then
slouken@1564
    13
    echo "Couldn't find autoconf, aborting"
slouken@1564
    14
    exit 1
slouken@1564
    15
fi
slouken@1380
    16
(cd test; sh autogen.sh)
slouken@0
    17
slouken@0
    18
# Run configure for this platform
slouken@0
    19
echo "Now you are ready to run ./configure"