music_mad.c
Sat, 21 Oct 2017 04:00:45 -0700 Fixed early termination playing MP3 files with libmad
Fri, 20 Oct 2017 23:39:04 -0700 Switched to using SDL_AudioStream in SDL 2.0.7 for better streaming resampling support
Tue, 17 Oct 2017 02:33:47 -0700 Rewrote music.c to support any number of decode libraries using a compiled-in plugin interface
Mon, 16 Oct 2017 02:13:21 -0700 music_mad.c: SDL_RWread() returns size_t, i.e. an unsigned value:
Mon, 16 Oct 2017 02:08:06 -0700 Fixed bug 3886 - mp3_mad broken when upsampling needed
Fri, 25 Aug 2017 21:27:59 -0700 Fixed bug 3773 - Cannot build with libmad support
Fri, 20 Jan 2017 02:23:51 -0500 Fixed music fading for Ogg Vorbis, libmad, and FLAC.
Sun, 01 Jan 2017 18:50:09 -0800 Updated copyright for 2017
Sat, 02 Jan 2016 10:46:07 -0800 Updated copyright to 2016
Mon, 03 Jun 2013 19:55:47 -0700 Fixed bug 1887 - libmad support broken
Sat, 01 Jun 2013 19:52:15 -0700 SDL_LoadMUS_RW() now takes an argument telling whether or not the data source should be freed when done.
Sat, 01 Jun 2013 10:11:20 -0700 Updated SDL_mixer with new versions of audio libraries, including SMPEG 2.0, and fixed Visual C++ build.
Tue, 21 May 2013 21:21:23 -0700 Cleaned up whitespace for the 2.0.0 release
Fri, 15 Feb 2013 14:58:54 -0800 Updated copyright year
Mon, 11 Feb 2013 20:51:13 -0800 Fixed missing return value, thanks to marius
Fri, 13 Jan 2012 03:15:19 -0500 Fixed memory crash loading Ogg Vorbis files on Windows
Wed, 04 Jan 2012 00:16:03 -0500 Fixed bug 1252 - Added Mix_LoadMUSType_RW() so you can tell SDL_mixer what type the music is
Sat, 31 Dec 2011 18:32:49 -0500 Fixed bugs 1003, 1021, 1168 - fixed memory leak loading music
Sat, 31 Dec 2011 10:27:48 -0500 Happy New Year!
Sun, 08 Nov 2009 17:11:09 +0000 Use RW_SEEK constants for RWseek()
Fri, 02 Oct 2009 14:16:12 +0000 Sam Lantinga - Fri Oct 2 07:15:35 PDT 2009
Mon, 08 Dec 2008 00:27:32 +0000 Updated copyright date
Tue, 12 Aug 2008 13:02:27 +0000 Fix bug 566, using wrong name for variable
Tue, 26 Feb 2008 11:44:20 +0000 Don't free the rwops if it wasn't allocated by the library!
Sun, 15 Jul 2007 05:33:35 +0000 Fixed bug #269