Mon, 16 Nov 2009 04:40:54 +0000Jon Atkins to Sam
Sam Lantinga <slouken@libsdl.org> [Mon, 16 Nov 2009 04:40:54 +0000] rev 481
Jon Atkins to Sam

I added libmodplug as a possible music player
defaulted to no in configure for now.
libmodplug has higher quality than mikmod, and it seems to be ported to all the major modern OS's (Linux/Win/OSX).

Sun, 15 Nov 2009 09:41:26 +0000warning: function declaration isn't a prototype release-1.2.11
Sam Lantinga <slouken@libsdl.org> [Sun, 15 Nov 2009 09:41:26 +0000] rev 480
warning: function declaration isn't a prototype

Sat, 14 Nov 2009 20:44:30 +0000Sam Lantinga - Sat Nov 14 12:38:01 PST 2009
Sam Lantinga <slouken@libsdl.org> [Sat, 14 Nov 2009 20:44:30 +0000] rev 479
Sam Lantinga - Sat Nov 14 12:38:01 PST 2009
* Fixed initialization error and crashes if MikMod library isn't available

Sat, 14 Nov 2009 20:38:24 +0000Sam Lantinga - Sat Nov 14 12:38:01 PST 2009
Sam Lantinga <slouken@libsdl.org> [Sat, 14 Nov 2009 20:38:24 +0000] rev 478
Sam Lantinga - Sat Nov 14 12:38:01 PST 2009
* Fixed crash on exit if the MikMod library isn't available

Sat, 14 Nov 2009 19:35:50 +0000Updated version to 1.2.11
Sam Lantinga <slouken@libsdl.org> [Sat, 14 Nov 2009 19:35:50 +0000] rev 477
Updated version to 1.2.11

Sat, 14 Nov 2009 19:31:39 +0000Sam Lantinga - Sat Nov 14 11:22:14 PST 2009
Sam Lantinga <slouken@libsdl.org> [Sat, 14 Nov 2009 19:31:39 +0000] rev 476
Sam Lantinga - Sat Nov 14 11:22:14 PST 2009
* Fixed bug loading multiple music files

Tue, 10 Nov 2009 03:22:08 +0000Max Horn to SDL
Sam Lantinga <slouken@libsdl.org> [Tue, 10 Nov 2009 03:22:08 +0000] rev 475
Max Horn to SDL

Unfortunately, this release does not compile on Mac OS X 10.5 anymore, due to using AudioComponentDescription, which is 10.6 only; yet the #ifdef's introduced recently (in revision 5190) assume it is available on 10.5, too.

To make it work right, one would have to check whether compiling for 10.6 *and* whether one is compiling using the 10.6 SDK. Note that
#if MAC_OS_X_VERSION_MIN_REQUIRED <= MAC_OS_X_VERSION_10_5
would not fix this, either, since MAC_OS_X_VERSION_MIN_REQUIRED can be e.g. 1058 (the actual value on my system); you'd want something like
#if MAC_OS_X_VERSION_MIN_REQUIRED < 1060
instead (since MAC_OS_X_VERSION_10_6 is not defined on older systems).

With the attached patch, it compiles again on my 10.5/intel/32bit system.

Sun, 08 Nov 2009 18:40:07 +0000Don't break binary compatibility! release-1.2.10
Sam Lantinga <slouken@libsdl.org> [Sun, 08 Nov 2009 18:40:07 +0000] rev 474
Don't break binary compatibility!

Sun, 08 Nov 2009 17:11:09 +0000Use RW_SEEK constants for RWseek()
Sam Lantinga <slouken@libsdl.org> [Sun, 08 Nov 2009 17:11:09 +0000] rev 473
Use RW_SEEK constants for RWseek()

Sun, 08 Nov 2009 17:03:07 +0000Fixed building with some audio support disabled
Sam Lantinga <slouken@libsdl.org> [Sun, 08 Nov 2009 17:03:07 +0000] rev 472
Fixed building with some audio support disabled