Mon, 19 Oct 2009 01:03:40 +0000Added the AudioUnit framework for the native MIDI code. release-1.2.9
Sam Lantinga <slouken@libsdl.org> [Mon, 19 Oct 2009 01:03:40 +0000] rev 462
Added the AudioUnit framework for the native MIDI code.

Mon, 19 Oct 2009 00:41:30 +0000Added volume control to Mac OS X Core MIDI native midi backend.
Ryan C. Gordon <icculus@icculus.org> [Mon, 19 Oct 2009 00:41:30 +0000] rev 461
Added volume control to Mac OS X Core MIDI native midi backend.

Sun, 18 Oct 2009 18:43:15 +0000Added patch note for Ryan's work
Sam Lantinga <slouken@libsdl.org> [Sun, 18 Oct 2009 18:43:15 +0000] rev 460
Added patch note for Ryan's work

Sun, 18 Oct 2009 18:38:07 +0000Added native midi support to the Xcode project
Sam Lantinga <slouken@libsdl.org> [Sun, 18 Oct 2009 18:38:07 +0000] rev 459
Added native midi support to the Xcode project

Sun, 18 Oct 2009 09:49:51 +0000Rewrote native Mac OS X MIDI support to be 10.6 and 64-bit clean.
Ryan C. Gordon <icculus@icculus.org> [Sun, 18 Oct 2009 09:49:51 +0000] rev 458
Rewrote native Mac OS X MIDI support to be 10.6 and 64-bit clean.

This uses Core MIDI now, instead of QuickTime, so it's Snow Leopard and 64-bit
compatible. There's one deprecated API used (still available in 10.6 and
64-bit, though), that is cool for 10.3 to 10.5...you can flip an #if to get
the 10.5-and-later, undeprecated API.

This is initial, first shot stuff, but it works with playmus. Please test!

Only updated configure script; Xcode project needs updating still.

Sun, 18 Oct 2009 06:08:22 +0000Updated Xcode project from Eric Wing:
Sam Lantinga <slouken@libsdl.org> [Sun, 18 Oct 2009 06:08:22 +0000] rev 457
Updated Xcode project from Eric Wing:

Meanwhile to bundle a framework transparently in the SDL_mixer framework so it is invisible to the end user, it appears that I actually have to build a formal "umbrella framework". These are a mystery and discouraged by Apple, but I think I got most of the details worked out with one fragile symlink that I don't understand why it is so fragile. Since we can depend on having 10.4, I can use @loader_path to help. I discovered @rpath requires 10.5. Code drop on this soon.

Sun, 18 Oct 2009 06:06:41 +0000Just look for the base .dylib files
Sam Lantinga <slouken@libsdl.org> [Sun, 18 Oct 2009 06:06:41 +0000] rev 456
Just look for the base .dylib files

Sun, 18 Oct 2009 04:31:26 +0000Added an Xcode project contributed by Eric Wing
Sam Lantinga <slouken@libsdl.org> [Sun, 18 Oct 2009 04:31:26 +0000] rev 455
Added an Xcode project contributed by Eric Wing

Sat, 17 Oct 2009 21:20:12 +0000Added the pkg-config files to the RPM
Sam Lantinga <slouken@libsdl.org> [Sat, 17 Oct 2009 21:20:12 +0000] rev 454
Added the pkg-config files to the RPM

Fri, 16 Oct 2009 13:39:46 +0000Eric Wing to Sam
Sam Lantinga <slouken@libsdl.org> [Fri, 16 Oct 2009 13:39:46 +0000] rev 453
Eric Wing to Sam

Deleted the exports files in the 4 projects.
Changed the build system to use gcc visibility.

image, mixer, net, ttf