Fri, 12 May 2006 05:08:03 +0000Added support for dynamically loading libjpeg, libpng, and libtiff.
Sam Lantinga <slouken@libsdl.org> [Fri, 12 May 2006 05:08:03 +0000] rev 143
Added support for dynamically loading libjpeg, libpng, and libtiff.

Fri, 12 May 2006 02:58:31 +0000Updated Xcode projects from Eric Wing
Sam Lantinga <slouken@libsdl.org> [Fri, 12 May 2006 02:58:31 +0000] rev 142
Updated Xcode projects from Eric Wing

Thu, 11 May 2006 19:10:17 +0000Updated version to 1.2.5
Sam Lantinga <slouken@libsdl.org> [Thu, 11 May 2006 19:10:17 +0000] rev 141
Updated version to 1.2.5

Thu, 11 May 2006 18:51:10 +0000Removed obsolete library file
Sam Lantinga <slouken@libsdl.org> [Thu, 11 May 2006 18:51:10 +0000] rev 140
Removed obsolete library file

Thu, 11 May 2006 18:46:23 +0000Updated Visual C++ project
Sam Lantinga <slouken@libsdl.org> [Thu, 11 May 2006 18:46:23 +0000] rev 139
Updated Visual C++ project

Wed, 03 May 2006 16:35:29 +0000Fixed execv warning when libtool creates wrapper executables
Sam Lantinga <slouken@libsdl.org> [Wed, 03 May 2006 16:35:29 +0000] rev 138
Fixed execv warning when libtool creates wrapper executables

Mon, 01 May 2006 09:09:45 +0000Date: Wed, 26 Apr 2006 17:02:52 +0200
Sam Lantinga <slouken@libsdl.org> [Mon, 01 May 2006 09:09:45 +0000] rev 137
Date: Wed, 26 Apr 2006 17:02:52 +0200
From: Julien Lecomte
Subject: Re: [SDL] SDL_image & libtiff

On 26/04/2006 13:43, I wrote:
> When configuring SDL_image with libtiff, libtiff wasn't found in my ca
se.
> I solved the problem by adding: 'LIBS="$LIBS $IMG_LIBS"' after line 16
3
> of configure.in ('if test x$enable_tif = xyes; then').
> I guess the problem is that my libtiff is a static lib, I didn't bothe
r
> to create the shared one, and that libtiff depends on libjpeg and libz
.
>
> I also guess that other static libraries (like possibly libpng) might
> share (sic) this problem.
>
> If I have a time, I'll review the configure.in and post a patch (don't

> use my solution above, it's ugly !)
>

Attached is a patch that modifies configure.in and makefile.am for
SDL_image.
*Changes are:*

- Checks for dependency libs before checking for other libraries (z is
checked before png, z and jpeg are checked before tiff) which was the
fix I was targetting (at the start)

Mon, 01 May 2006 08:00:49 +0000Packed the OS/2 build files into Watcom-OS2.zip
Sam Lantinga <slouken@libsdl.org> [Mon, 01 May 2006 08:00:49 +0000] rev 136
Packed the OS/2 build files into Watcom-OS2.zip

Mon, 01 May 2006 07:24:22 +0000Don't add NONE/bin to the path - inexplicably fixes building on mingw+msys, apparently
Sam Lantinga <slouken@libsdl.org> [Mon, 01 May 2006 07:24:22 +0000] rev 135
Don't add NONE/bin to the path - inexplicably fixes building on mingw+msys, apparently

Mon, 01 May 2006 03:24:32 +0000Added support for C++ and assembly files, and source in subdirectories
Sam Lantinga <slouken@libsdl.org> [Mon, 01 May 2006 03:24:32 +0000] rev 134
Added support for C++ and assembly files, and source in subdirectories