Fri, 15 Feb 2013 14:47:06 -0800Updated copyright year
Sam Lantinga <slouken@libsdl.org> [Fri, 15 Feb 2013 14:47:06 -0800] rev 347
Updated copyright year

Fri, 15 Feb 2013 14:28:08 -0800Added debian packaging for SDL2_image
Sam Lantinga <slouken@libsdl.org> [Fri, 15 Feb 2013 14:28:08 -0800] rev 346
Added debian packaging for SDL2_image

Thu, 14 Feb 2013 09:11:19 -0800Bug 1720: fix issues in VS2012 solution/project files (contributed by Hiroyuki Iwatsuki)
Andreas Schiffler <aschiffler@ferzkopp.net> [Thu, 14 Feb 2013 09:11:19 -0800] rev 345
Bug 1720: fix issues in VS2012 solution/project files (contributed by Hiroyuki Iwatsuki)

Tue, 12 Feb 2013 07:19:08 -0800Merged with tip
Andreas Schiffler <aschiffler@ferzkopp.net> [Tue, 12 Feb 2013 07:19:08 -0800] rev 344
Merged with tip

Sun, 03 Feb 2013 08:37:28 -0800Added VS2010 and VS2012 projects; updates for VS compile; fixes from VS code analysis and code review
Andreas Schiffler <aschiffler@ferzkopp.net> [Sun, 03 Feb 2013 08:37:28 -0800] rev 343
Added VS2010 and VS2012 projects; updates for VS compile; fixes from VS code analysis and code review

Fri, 08 Feb 2013 01:09:26 -0800Fixed bug 1698 - XPM colors can be in upper case and/or lower case
Sam Lantinga <slouken@libsdl.org> [Fri, 08 Feb 2013 01:09:26 -0800] rev 342
Fixed bug 1698 - XPM colors can be in upper case and/or lower case

Sylvain

Due to previous commits, there is a regression : some xpm does not load because
of color name not found.

You called "toupper" before, and now only using "SDL_strncmp" to look for xpm
color name.

In a xpm file, colors can be in Lower and/or Upper case !
So, we need to call "SDL_strncasecmp".

Sun, 27 Jan 2013 15:55:03 -0800Updated build settings to use standard architectures
Sam Lantinga <slouken@libsdl.org> [Sun, 27 Jan 2013 15:55:03 -0800] rev 341
Updated build settings to use standard architectures

Tue, 01 Jan 2013 11:40:47 -0800Fixed bug 1413 - Cannot load images with ImageIO enabled on Mac OS X
Sam Lantinga <slouken@libsdl.org> [Tue, 01 Jan 2013 11:40:47 -0800] rev 340
Fixed bug 1413 - Cannot load images with ImageIO enabled on Mac OS X

The attached diff fixes the library so ImageIO can be used and images are
displayed again without corruption and black screens.

(Based on http://pastebin.com/T3s15UXF and
http://www.brucelindbloom.com/index.html?Eqn_RGB_XYZ_Matrix.html)

I suspect the matrix passed to CGColorSpaceCreateCalibratedRGB() as implemented
in r292 is invalid and the CoreGraphics framework on 10.5 doesn't reject it,
but later ones do. Unfortunately all the documentation I can find doesn't
actually specify what the valid range of values of the arguments is.

Thu, 22 Nov 2012 13:10:41 -0800Fixed bug 1640 - More colors recognized for XPM format
Sam Lantinga <slouken@libsdl.org> [Thu, 22 Nov 2012 13:10:41 -0800] rev 339
Fixed bug 1640 - More colors recognized for XPM format
The table is in IMG_xpm.c and is disabled by default because it increases the library size by 40K.

Sun, 28 Oct 2012 13:32:24 -0700Don't install the static library, search for the framework in the application bundle Frameworks directory.
Sam Lantinga <slouken@libsdl.org> [Sun, 28 Oct 2012 13:32:24 -0700] rev 338
Don't install the static library, search for the framework in the application bundle Frameworks directory.