Updated for DirectDB 0.9.15 (thanks Denis!)
authorSam Lantinga <slouken@libsdl.org>
Sun, 17 Nov 2002 19:36:49 +0000
changeset 5460009aadb3d01
parent 545 8406511f850e
child 547 5d07f9a47f17
Updated for DirectDB 0.9.15 (thanks Denis!)
configure.in
src/video/directfb/SDL_DirectFB_video.c
     1.1 --- a/configure.in	Sun Nov 17 19:30:44 2002 +0000
     1.2 +++ b/configure.in	Sun Nov 17 19:36:49 2002 +0000
     1.3 @@ -783,7 +783,7 @@
     1.4                  AC_MSG_ERROR([*** pkg-config too old; version 0.7 or better required.])
     1.5              fi
     1.6  
     1.7 -            DIRECTFB_REQUIRED_VERSION=0.9.14
     1.8 +            DIRECTFB_REQUIRED_VERSION=0.9.15
     1.9  
    1.10              if $PKG_CONFIG --atleast-version $DIRECTFB_REQUIRED_VERSION directfb ; then
    1.11                  DIRECTFB_CFLAGS=`$PKG_CONFIG --cflags directfb`
     2.1 --- a/src/video/directfb/SDL_DirectFB_video.c	Sun Nov 17 19:30:44 2002 +0000
     2.2 +++ b/src/video/directfb/SDL_DirectFB_video.c	Sun Nov 17 19:36:49 2002 +0000
     2.3 @@ -394,7 +394,7 @@
     2.4        goto error;
     2.5      }
     2.6  
     2.7 -  ret = dfb->CreateEventBuffer (dfb, DICAPS_ALL, &events);
     2.8 +  ret = dfb->CreateInputEventBuffer (dfb, DICAPS_ALL, DFB_FALSE, &events);
     2.9    if (ret)
    2.10      {
    2.11        SetDirectFBerror ("dfb->CreateEventBuffer", ret);