Sun, 22 Jan 2012 18:37:46 -0500Re-added SDL_SWSURFACE, because it looks silly to always pass 0 to SDL_CreateRGBSurface()
Sam Lantinga [Sun, 22 Jan 2012 18:37:46 -0500] rev 6257
Re-added SDL_SWSURFACE, because it looks silly to always pass 0 to SDL_CreateRGBSurface()

Sun, 22 Jan 2012 18:11:41 -0500Removed the SDL 1.2 compatibility API... we'll see how painful this is.
Sam Lantinga [Sun, 22 Jan 2012 18:11:41 -0500] rev 6256
Removed the SDL 1.2 compatibility API... we'll see how painful this is.

Sun, 22 Jan 2012 17:50:35 -0500Switched the RPM spec file to SDL 2.0
Sam Lantinga [Sun, 22 Jan 2012 17:50:35 -0500] rev 6255
Switched the RPM spec file to SDL 2.0

Sun, 22 Jan 2012 17:41:33 -0500Removed unsupported Watcom files
Sam Lantinga [Sun, 22 Jan 2012 17:41:33 -0500] rev 6254
Removed unsupported Watcom files

Sun, 22 Jan 2012 17:33:44 -0500BeOS is no longer a going concern. ;)
Sam Lantinga [Sun, 22 Jan 2012 17:33:44 -0500] rev 6253
BeOS is no longer a going concern. ;)

Sun, 22 Jan 2012 17:32:50 -0500Removed unsupported Borland related files
Sam Lantinga [Sun, 22 Jan 2012 17:32:50 -0500] rev 6252
Removed unsupported Borland related files

Sun, 22 Jan 2012 17:26:45 -0500Removing some more references to SDL 1.3
Sam Lantinga [Sun, 22 Jan 2012 17:26:45 -0500] rev 6251
Removing some more references to SDL 1.3

Sun, 22 Jan 2012 17:21:00 -0500Updated to SDL 2.0, and SDL 2.0 can now be installed coexisting with SDL 1.2
Sam Lantinga [Sun, 22 Jan 2012 17:21:00 -0500] rev 6250
Updated to SDL 2.0, and SDL 2.0 can now be installed coexisting with SDL 1.2

Sun, 22 Jan 2012 13:47:21 -0500Fixed bug 1390 - X11_KeyToUnicode SDL-1.2
Sam Lantinga [Sun, 22 Jan 2012 13:47:21 -0500] rev 6249
Fixed bug 1390 - X11_KeyToUnicode

manuel.montezelo 2012-01-22 08:56:18 PST

We had the following bug report at Debian:
http://bugs.debian.org/376560

Same one in Ubuntu:
https://bugs.launchpad.net/ubuntu/+source/libsdl1.2/+bug/66217

We've been including a patch since then (attached) to actually export the
symbol, since 2006. In the last release the function seems to be there, alive
and kicking.

It's affecting other people too:
http://www.garagegames.com/community/forums/viewthread/52287

Sun, 22 Jan 2012 01:29:26 -0500You need to create the texture with the SDL_TEXTUREACCESS_TARGET flag.
Sam Lantinga [Sun, 22 Jan 2012 01:29:26 -0500] rev 6248
You need to create the texture with the SDL_TEXTUREACCESS_TARGET flag.