README-android.txt
changeset 7907 24b4e98c6010
parent 7804 1f85fb33694b
child 7944 f19c0aca56aa
     1.1 --- a/README-android.txt	Sun Nov 03 11:34:03 2013 -0800
     1.2 +++ b/README-android.txt	Tue Nov 05 20:07:39 2013 -0300
     1.3 @@ -4,13 +4,14 @@
     1.4  
     1.5  Requirements:
     1.6  
     1.7 -Android SDK (version 10 or later)
     1.8 +Android SDK (version 12 or later)
     1.9  http://developer.android.com/sdk/index.html
    1.10  
    1.11  Android NDK r7 or later
    1.12  http://developer.android.com/sdk/ndk/index.html
    1.13  
    1.14  Minimum API level supported by SDL: 10 (Android 2.3.3)
    1.15 +Joystick support is available for API level >=12 devices.
    1.16  
    1.17  ================================================================================
    1.18   How the port works
    1.19 @@ -396,8 +397,11 @@
    1.20   Why is API level 10 the minimum required?
    1.21  ================================================================================
    1.22  
    1.23 -API level 10 is required because SDL requires some functionality for running not
    1.24 -available on older devices and some for building which is not in older NDK/SDKs.
    1.25 +API level 10 is the minimum required level at runtime (that is, on the device) 
    1.26 +because SDL requires some functionality for running not
    1.27 +available on older devices. Since the incorporation of joystick support into SDL,
    1.28 +the minimum SDK required to *build* SDL is version 12. Devices running API levels
    1.29 +10-11 are still supported, only with the joystick functionality disabled.
    1.30  
    1.31  Support for native OpenGL ES and ES2 applications was introduced in the NDK for
    1.32  API level 4 and 8. EGL was made a stable API in the NDK for API level 9, which