configure.in
changeset 868 e805075f6d94
parent 865 92615154bb68
child 873 89666943c598
equal deleted inserted replaced
867:5c7859610bc4 868:e805075f6d94
   296         ])
   296         ])
   297         if test x$have_alsa = xyes; then
   297         if test x$have_alsa = xyes; then
   298             AC_ARG_ENABLE(alsa-shared,
   298             AC_ARG_ENABLE(alsa-shared,
   299 [  --enable-alsa-shared     dynamically load ALSA audio support [default=yes]],
   299 [  --enable-alsa-shared     dynamically load ALSA audio support [default=yes]],
   300                           , enable_alsa_shared=yes)
   300                           , enable_alsa_shared=yes)
   301             alsa_lib=`ls /usr/lib/libasound.so.* | head -1 | sed 's/.*\/\(.*\)/\1/'`
   301             alsa_lib=`ls /usr/lib/libasound.so.* | sed 's/.*\/\(.*\)/\1/; q'`
   302             if test x$use_dlopen != xyes && \
   302             if test x$use_dlopen != xyes && \
   303                test x$enable_alsa_shared = xyes; then
   303                test x$enable_alsa_shared = xyes; then
   304                 AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
   304                 AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
   305             fi
   305             fi
   306             if test x$use_dlopen = xyes && \
   306             if test x$use_dlopen = xyes && \
   354         if test x$use_esd = xyes; then
   354         if test x$use_esd = xyes; then
   355             AC_ARG_ENABLE(esd-shared,
   355             AC_ARG_ENABLE(esd-shared,
   356 [  --enable-esd-shared     dynamically load ESD audio support [default=yes]],
   356 [  --enable-esd-shared     dynamically load ESD audio support [default=yes]],
   357                           , enable_esd_shared=yes)
   357                           , enable_esd_shared=yes)
   358             esd_lib_spec=`echo $ESD_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libesd.so.*/'`
   358             esd_lib_spec=`echo $ESD_LIBS | sed 's/.*-L\([[^ ]]*\).*/\1\/libesd.so.*/'`
   359             esd_lib=`ls $esd_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
   359             esd_lib=`ls $esd_lib_spec | sed 's/.*\/\(.*\)/\1/; q'`
   360             echo "-- $esd_lib_spec -> $esd_lib"
   360             echo "-- $esd_lib_spec -> $esd_lib"
   361             if test x$use_dlopen != xyes && \
   361             if test x$use_dlopen != xyes && \
   362                test x$enable_esd_shared = xyes; then
   362                test x$enable_esd_shared = xyes; then
   363                 AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
   363                 AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
   364             fi
   364             fi
   405             if test x$audio_arts = xyes; then
   405             if test x$audio_arts = xyes; then
   406                 AC_ARG_ENABLE(arts-shared,
   406                 AC_ARG_ENABLE(arts-shared,
   407 [  --enable-arts-shared    dynamically load aRts audio support [default=yes]],
   407 [  --enable-arts-shared    dynamically load aRts audio support [default=yes]],
   408                               , enable_arts_shared=yes)
   408                               , enable_arts_shared=yes)
   409                 arts_lib_spec="$ARTSC_PREFIX/lib/libartsc.so.*"
   409                 arts_lib_spec="$ARTSC_PREFIX/lib/libartsc.so.*"
   410                 arts_lib=`ls $arts_lib_spec | head -1 | sed 's/.*\/\(.*\)/\1/'`
   410                 arts_lib=`ls $arts_lib_spec | sed 's/.*\/\(.*\)/\1/; q'`
   411                 echo "-- $arts_lib_spec -> $arts_lib"
   411                 echo "-- $arts_lib_spec -> $arts_lib"
   412                 if test x$use_dlopen != xyes && \
   412                 if test x$use_dlopen != xyes && \
   413                    test x$enable_arts_shared = xyes; then
   413                    test x$enable_arts_shared = xyes; then
   414                     AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
   414                     AC_MSG_ERROR([You must have dlopen() support and use the --enable-dlopen option])
   415                 fi
   415                 fi