autogen.sh
author Ryan C. Gordon
Mon, 21 Aug 2017 00:42:06 -0400
changeset 11334 749cb40916f2
parent 10722 30e271a26a02
permissions -rwxr-xr-x
x11: specify event mask for buttons when grabbing pointer (thanks, Stas!).

This fixes a strange corner case (notes appended below), and should be
safe to do anyhow.

Fixes Bugzilla #3674.

"I did more tests.
It appears the bug only happens if there is
another window on the screen that has "always
on top" property. For me it is xawtv - it is
always opened in a screen corner. Closing
xawtv or removing "always on top" property
from it makes the problem to go away.
Plus, it doesn't appear like the buttons are
not delivered at all. It appears that instead
the button presses are delivered on some mouse
positions, but not delivered when you move the
mouse to other part of the window... So this is
really weird and is likely somewhere deep in the
Xorg.
Maybe somehow it happens that the cursor is
actually above the xawtv window, but, because
my app uses grab, it is not visible there, and
in that case the events are not delivered to
my app?
But with my patch the button events are
always delivered flawlessly, it seems.

Hmm, and that indeed seems to explain my problem:
if the mask is set properly and my app uses
grab, then, even if the mouse is above some
other window, the events would still be delivered
to the grabbing app, which is what actually wanted
because my app uses relative mouse mode, so it
doesn't know the pointer can cross some other window
(my app draws the pointer itself).
So my current theory is that my patch only enforces
the mouse grab, which otherwise can be tricked by
some other window preventing the button events
delivery (but motion events are still delivered
via xinput2, which makes it all look very obscure)."
slouken@0
     1
#!/bin/sh
slouken@0
     2
#
slouken@1376
     3
echo "Generating build information using autoconf"
slouken@0
     4
echo "This may take a while ..."
slouken@0
     5
hadess@10398
     6
srcdir=`dirname $0`
hadess@10398
     7
test -z "$srcdir" && srcdir=.
icculus@10722
     8
cd "$srcdir"
hadess@10398
     9
slouken@0
    10
# Regenerate configuration files
slouken@7232
    11
cat acinclude/* >aclocal.m4
slouken@1564
    12
found=false
slouken@1832
    13
for autoconf in autoconf autoconf259 autoconf-2.59
slouken@1564
    14
do if which $autoconf >/dev/null 2>&1; then $autoconf && found=true; break; fi
slouken@1563
    15
done
slouken@1564
    16
if test x$found = xfalse; then
slouken@1564
    17
    echo "Couldn't find autoconf, aborting"
slouken@1564
    18
    exit 1
slouken@1564
    19
fi
slouken@1380
    20
(cd test; sh autogen.sh)
slouken@0
    21
slouken@0
    22
# Run configure for this platform
slouken@0
    23
echo "Now you are ready to run ./configure"